
 

Newsletter - February 2017 

GPR-SLICE users,  

We would like to welcome the following organizations to the GPR-SLICE 
community 

 Ceratonia Geophysics S.r.l, Ragusa, Italy (www.ceratonia.it) 
 Capital Normal University, China 
 Serramur & Asociates, PC, Boone, North Carolina (www.seramur-

associates.com) 

 Proceq, Switzerland (www.proceq.com) 
 Seismic and Exploration Geophysics, University of Bassra, Iraq 

 Dept of History, Geography and Philosophy, University of Cadiz, Spain 
 Dept of Earth Sciences, University of Florence, Italy 

 ScanTech Geoscience, Ireland (www.scantech.ie) 
 Dept of Earth Sciences, University of Memphis, Tennessee 

 Soft Options, New Zealand 
 Gyula Forster National Centre for Cultural Heritage Management, 

Hungary 
 Sum Kee Construction Limited, Hong Kong (www.sumkee.com.hk) 

 Peter Lanzarone 
 Jorge Alarcon Anthropologist, Bogota, Colombia 

 Anomali Jeoteknik Muhendislik Hizm Ltd, Turkey 
(www.anomali.com.tr) 

 GeoPat, France 

 BHP Billiton, Canada 
 

http://www.ceratonia.it/
http://www.seramur-associates.com/
http://www.seramur-associates.com/
http://www.sumkee.com.hk/
http://www.anomali.com.tr/


 

GeoStudi in Italy, a long time user of GPR-SLICE + Multichannel options 

ordered a second license to the software.    

 

GPRSIM Software licenses were delivered to: Corpo 

 North China University of Science and Technology 

 Changjian River Surveying Technology Research Institute, China 
 BHP Billiton, Canada 

 

Software Updates 

     Among the most important or requested improvements added to GPR-
SLICE V7.0 Software are: 

 Vector volume addition – example of a square column survey 
 Spectral + Gain menu – application of gain w/bandpass 

 GPS listings spreadsheet 
 OpenGL Volume Draw Objects editing spreadsheet 

 Differential Bandpass filtering 
 DXF file export of object depth from local topography 

 

Vector Volume Addition –example imaging of a 4-sided square column 

     GPR-SLICE has a new menu to synthesize a vector volume from separate 

localized volumes (Figure 1) This menu can be used for instance to combine 

all the surface surveys and their separate volumes taken on a 4-sided square 

column and generate a single vector volume! The new menu on the 3D volume 

pull down menu has slots to set the absolute origin that each volume is 

recorded on, along with their corresponding axes rotation needed to place the 

new volumes in their vector location. There are also separate gain values that 

can be applied during the addition process for each individual volume.  

 

     Some of the requirements and recommendations for this new vector 

operation are to: 1) make individual volumes that have more density then the 

output volume to insure that there are no empty cells during rotation and 

translation into the output vector volume, and 2) it is recommended that 

absolute or ABSOLUTE (user defined set min/man) normalization be used to 



 

generate the volumes. With absolute normalization, keeping the gains lower 

at depth in each individual volume will help to ensure that volume elements 

that are overlapped - as will occur on the corners of the new volume - do no 

overwhelm the imagery - and only the true amplitudes are being added and 

not normalized amplitudes at each level from the time slice dataset. An 

example of a column concrete/rebar survey made with a Sensors and Software 

Conquest GPR system by Butch Federizon at Geomaster Corp in Quezon City 

in the Philippines is shown in the example imagery (Figure 2).  

 

 

Figure 1.  The new Vector Volume Addition menu 



 

 

 

Figure 2.  Example of vector volume addition on a GPR survey  made on a 4 

sided square column  (survey data courtesy of Butch Federizon, Geomaster Corp, 

Philippines) 

 

 

     This new option is not limited to just 4 volumes. The menu can be run 

several times with the output volumes as input volume to comprise many 

more locations into a single vector volume. The size of the output volume if 

areas are separate by large distances can become "intolerable" for volume 

memory and it is recommended that adjacent areas be used to keep the 

output volume manageable. The vector volumes are distinguished from our 

typical volumes in that the z axis is no longer measured in time and the volume 

is a depth volume. Time axes will not appear in OpenGL for these new vector 

volume displays. 



 

GPS Listings Spreadsheet 

     GPS navigation files that are made for each radargram in the information 

file can be easily accessed using the Show GPS File buttons in both the GPS 

track menu and in the Edit Info File menu (Figure 3).  The GPS data will be 

presented in a spreadsheet available for additional editing if needed and can 

be used to quickly identify problem GPS points in the file.   The 8 columns 

shown are the eastings, northings, elevation, time, scan#, gps quality, # of 

satellites and the HDOP.  (GPS navigation files are 20 columns long with 

columns 9,10, 11 which are reserved for vector scan definitions, and 9 

columns leftover for future growth) 

 

Figure 3. New Show GPS File spreadsheet in the GPS Track Menu. 

 

 



 

OpenGL Draw Objects Spreadsheet 

     Drawn objects in OpenGL Volume Draw can be easily accessed using the 
new spreadsheet button Edit Objects (Figure 4).    The spreadsheet can be 
used to easily reassign color or width/height/length settings for any object in 

the list as well as delete objects.   A text descriptor to be shown in OpenGL on 
any point, line node, pipe or rectangle can also be easily added on any object 

with the new menu. 

 

 

Figure 4.  New Edit Object spreadsheet in OpenGL Volume Draw menu. 

 

 

 



 

Spectra + Gain menu  

 

     A new menu called Spectra+Gain is available in the Filter pulldown menu 

(screen shot 1). This menu allows the user to apply range gain on the 
radargram pulses real-time with the bandpass filter engaged. The radargram 

that is displayed will be the instantaneous radargram with the gaining and 
bandpass applied. The menu can be used as an alternative/addition to 

removing wobble or the dc offset on the raw radargrams. 

 

     For GPR equipment that already have bandpass filtering applied to the raw 
recorded data, this new menu may not have such a large impact on your 

processing steps and your final imagery. However, for those surveys where 
bandpass is not engaged in the GPR control unit and is not recorded into the 

raw radargrams, this range gain feature set in the Spectra menu, can provide 
an alternative and perhaps superior method to condition the raw pulses than 

simple wobble removal. An example of a dataset which appears to be quite 

noisy – with an extreme dc offset - and was recorded without bandpass filters 
in the raw data is shown in Figure 5. The raw-ungained pulse (s) show a small 

offset that when gained without bandpass are completely out of the binary 
resolution and are clipped (Figure 6). The bandpass application with 

simultaneous gaining will insure that the raw filtered pulses are within range 
and the wobble/dc offset removed. 

Note: 1) recommendations are to use this new menu with time 0 edited 

radargams to avoid FFT (Fast Fourier Transform) wrap around effects that can 
cause noises above the 0 sample if not removed.  This can potentially lead to 

false definitions of time 0 on processed radargrams. 

Note 2) batch gain rather than batch gain - wobble in the convert menus will 
typically be used without any range gain engaged if the new Spectra + Gain 

menu will be implemented 

 



 

 

Figure 5.  Generation of a range gain curve with application to simultaneous 
bandpass filtering.    



 

 

Figure 6.  Example of an ungained radargram where bandpass+gain are added 
simultaneous.  A comparison with gain without bandpass filter engaged is 

shown. 

 

Customizable scan start/end for application of bandpass filters 

 

     A new option to apply bandpass filtering just to a set of selective scans in 
a dataset in which there are severe noise issues, without having to apply the 
filter across the entire radargram was added to the Filter menu.  To 



 

accommodate this request a new flag option - set in the Filter menu will read 

the XYpoints file to discover those scan sections to apply the customized 
processing on (screen shot 1). The scan start/end values are set via the 

XYpoints operation, and should be made consecutively across the radargram. 
(XYpoints record among other things, the scan # of the chosen anomaly 

points, which makes this features convenient for providing this specialized 
feature.  

 

Note: This new option currently requires working with an info.dat file with just 

the single radargram name for the differential bandpass filtering to be applied 
to. 

 

 

Figure 7.  Example of setting consecutive points for application of bandpass 
filtering using the XYPoints operation (right mouse click on graphic). 



 

 

Figure 8.  Example of differential bandpass filtering following the XYpoints 
junctures chosen for the radargram. 

 

DXF Export of Depth from the Local Topographic Surface 

     In the OpenGL Volume Draw menu a variety of DXF export files are made 
to accommodate user requests.  The latest export option provides a DXF 

export file that will report the local depth from the local topography for the 
drawn object (Figure 9).   For this option to work, there must have been a 

topographic grid created that was used to generate the binary corrected 
topographic radargrams in the project.  Anomaly points are then chosen in 

the 2D radargram menu on the \topo\ folder (Figure 10).   With import to 

OpenGL Volume Draw using the XYpoints button, DXF export will write the 
absolute depth as well as display the local depth as labels from the ground 

surface for the anomaly points in AutoCAD.   

 



 

Figure 9.  DXF file output w/depth labels from the local topographic surface. 

 

Figure 10.  Generation of XYpoints on top of topographically/binary corrected 
radargrams 



 

Other features and options added to GPR-SLICE include: 

 Animation menu and exportable animation enhanced with scale slider 
bar (1/31/17).  GSSI Structure Scan Mini XT format added (1/31/17).  

 For colors, the standard American Public Works Association has been set 

as the default colors for object drawing as requested by several users: 
 http://www.engineersupply.com/APWA-Utility-Color-Codes.aspx 

 IDS Stream *.gec main track GPS navigation read included in the Edit 

Info File menu  - can substitute for *.geox when used in conjunction 

with xy channel offsets and Array To Nav operations with 

infochannels.dat active  

  FK radargram 8 bit radargram support added to Filter menu.    

 Loza Russian GPR 7 bit  to 8 bit radargram support added to 

Conversion menu.   

 Mala Object Mapper beta read included in Create New Info menu  

 Transient Technologies of the Ukraine GPR equipment format added to 

Conversion menu.  GPS distance added to horizon export file 

(12/29/16).   

 Closest point of approach calculation made on horizon core GPS 

location for display on a 2D GPS radaragram display.   

 Triple labeling in OpenGL with zscan#, time and depth.    

 4 corner ESRI world file designation for local grid georeferencing added 

to Pixel Map menu     

 XYZ to NAV import option in the the Edit Info File menu enhanced to 

include vector calculations from the x and y import navigation for 

assuming horizontal application of the antenna where it is normal to 

the z plane (e.g. horizontal) (12/6/16).    

 Spiking - deterministic deconvolution, spectral wavelet-signal 

convolution deconvolution and beta predictive deconvolution added to 

the Filter menu 

 Batch preview graphic shutoff on FK filtering added to significantly 

speed up processing 10-20 times faster.   

 Limitation in FK radargram filtering removed so that radargrams of 

different lengths can be processed with the same FK filter in batch 

processing - all data resampled to the longest radargram in the 

project.   

 Draw_track.dat layer creation added to OpenGL Volume Draw menu to 

create a separate GPS/XY track object file that can be appended to 

the drawn object file.    

http://www.engineersupply.com/APWA-Utility-Color-Codes.aspx


 

 Explicit time window/depth window radio button for time slice labeling 

option in the Pixel Maps added to Options menu (11/7/16).   

 APWA American Public Works Association recommended color 

designations for underground 

utilities/surveys/excavations/sewers/water/reclaimed 

water/communications/gas/electric set as the default colors in OpenGL 

Volume Draw menu.   

 OpenGL Volume XY element skip option to allow display of super large 

volumes - setting added to the Options menu 

 OpenGL Volume Draw menu kml exports now also includes sphere 

objects which will translate into Google Earth pushpin displays.   

 GPR-SLICE time/depth/velocity labeling generalized to be able to 

handle GPR or Seismic datasets - time and depth units set in the 

Options menu.   

 Delete 0,0 null navigation points added to GPS Track menu.   

 Scan stacking/decimation added to Filter menu - currently available 

only for GPS/vector radargrams.    

 GPR-SLICE Animation Menu - internal and the export menu-  updated 

for auto-resizing to the dialog size along with vector graphic resizing 

for cleaner scaling.   ‘Binary radargram appending in the Radar Edit 

menu will now include associated GPS log files.   

 SEG-2 IEEE 32 bit format added to convert menu.   

 BlueBox Run Regain menu wobble option added - useful for surveys 

where time 0 corrections are done.  

  OpenGL Speed option for skipping scans on over sampled radargrams 

and improving display speed, added to the Options menu.   

 Re-export of *.sgy, *.dzt, *.rd3, *.dt1, *.dt  processed GPR-SLICE 

radargrams back to original manufacturer's file format available in the 

Filter menu.  

 Improved filtering of bad GPS removing the top 10% and bottom 10% 

of readings to discover a better average and to remove GPS points a 

desired distance error from the average.    

 Subscribers Only page launch to check the update version available on 

the Help menu.   

 Boxcar radargram filter reengineered to be able to handle super large 

radargrams > 500k scan and for increased processing speed.   

 Auto arrange dialog button added to XYpoints operation for GPS 

radargrams with the sync GPS track plot active. 



 

     We are accepting sponsorship for the next GPR-SLICE 2-day workshop.  If 

there are any universities or organizations that are interested in hosting the 

next GPR-SLICE workshop that can handle up to 30 attendees, please let us 

know.  The dates for the workshop are flexible and would be based on the 

level of interest. 

 

Facebook Forum 

    The Facebook Forum for GPR-SLICE has been actively used and is a useful 

resource for finding more in-depth answers and discussion on relevant GPR-
SLICE software topics.  All the new options have been first introduced in the 

Facebook forum for GPR-SLICE right at the time they were developed and 
released.    If you have not yet joined the GPR-SLICE Facebook page, I would 

encourage you to do so at: 

    https://www.facebook.com/groups/gpr.slice/   
 

_________________________________ 

Dean Goodman 
GPR-SLICE Software 

 
 

 
*This newsletters is available in *.pdf form on the Subscribers Only page of the 

website 

https://www.facebook.com/groups/gpr.slice/

